Office 365 : Online Portal Issues
Incident Report for Melbourne IT Status Page
Resolved
We would like to inform our Office 365 customers that all online portal issues have been resolved. Microsoft have confirmed that customers can now login to the online portal, as well as, send emails without experiencing long delays.
Posted Apr 22, 2020 - 16:54 AEST
Update
We would like to inform our customers that the issue logging into the Office 365 web portal has been resolved. Customers will be able to login to their Office 365 emails online.

The issue with sending out emails through the Office 365 web portal is still being investigated. Customers may experience delays of up to four hours when sending mail. Users may notice that their mail will be stuck in their "Outbox" folder for the duration of the delay.
Posted Apr 22, 2020 - 10:14 AEST
Identified
We would like to inform our customers that there is currently service degradation with sending emails and logging into the Office 365 online portal. This is currently being investigated by Microsoft.

In the interim, we suggest customers connect their office 365 email accounts to an email client and continue using their emails this way or try again later.
Posted Apr 21, 2020 - 15:52 AEST
This incident affected: Professional Email (Office 365).