Email Delivery Disruption
Incident Report for Melbourne IT Status Page
Resolved
We would like to advise our customers that after closely monitoring our managed exchange platform, we are confident that services have returned back to normal and are stable.
Posted about 1 month ago. Oct 16, 2018 - 10:40 AEDT
Monitoring
We would like to advise customers that we have recently experienced email delivery issues on our managed exchange platform.

Our technicians have restored these services, however we will be closely monitoring these services to prevent any further disruptions.
Posted about 1 month ago. Oct 15, 2018 - 13:04 AEDT
This incident affected: Legacy Hosting (Managed Exchange Mail).