Payment Gateway - Service Interruption
Incident Report for Melbourne IT Status Page
Resolved
This incident has now been resolved.
Posted 27 days ago. Nov 17, 2018 - 20:38 AEDT
Investigating
We are currently experiencing technical difficulties with our payment gateway services. This is currently preventing customers from processing payments. Our system administrators are currently investigating and working to resolve this issue as a priority.

We will update this service alert as more information becomes available.
Posted 28 days ago. Nov 17, 2018 - 16:07 AEDT
This incident affected: Network Infrastructure (Internal Network) and Account Interfaces (Hosting console, Domainz Account, Domain Name Management).