Payment Interruptions
Incident Report for Melbourne IT Status Page
Resolved
This incident has been resolved.
Posted 4 months ago. May 11, 2019 - 10:35 AEST
Identified
We would like to advise that we are currently experiencing a technical issue which is preventing us from processing payments
This is being looked into by our development team

We apologise for any inconvenience this may cause and thank you for your patience while we have this addressed
Posted 4 months ago. May 11, 2019 - 10:04 AEST
This incident affected: Network Infrastructure (Internal Network) and Account Interfaces (Domain Name Management).