Phone System Service Disruption
Incident Report for Melbourne IT Status Page
Resolved
We would like to advise that our phone systems have now returned back online.
Posted 7 months ago. Mar 08, 2019 - 09:22 AEDT
Investigating
We are currently experiencing issues with our phone systems.

Our technicians are looking into this as a priority. Live chat and email support are unaffected by this issue, although wait times may be longer than usual.

We apologize for the inconvenience this incident may cause you
Posted 7 months ago. Mar 07, 2019 - 22:48 AEDT
This incident affected: Support Centre (24h Phone Support).