Melbourne IT - Phone Support Interruption
Incident Report for Melbourne IT Status Page
Resolved
Phone systems have been restored and no further issues have been identified since yesterday.

Apologies for any inconvenience this may have caused.
Posted 8 months ago. Feb 03, 2017 - 10:31 AEDT
Investigating
We wish to advise our customers we are currently experiencing technical difficulties with our phone support system. Our platform engineers are currently investigating this as a high priority.

Customers requiring support can still use our live chat and email services to contact us.

Thank you for your patience while we address this interruption
Posted 8 months ago. Feb 02, 2017 - 16:31 AEDT
This incident affected: Support Centre (24h Phone Support).