Degraded Performance: Phone Support systems
Incident Report for Melbourne IT Status Page
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 05, 2017 - 21:18 AEST
Identified
Currently some of our customer service staff are experiencing some technical difficulties. Our internal technicians have identified the root cause and are working to bring service back to full capacity as quickly as possible, but in the meantime call wait times may be longer than average.

We thank you for your patience as we work through this.
Posted 3 months ago. Sep 05, 2017 - 09:08 AEST