Website and Console outage
Incident Report for Melbourne IT Status Page
Resolved
At this stage we believe the access issue has been resolved. Customers websites and ours are back up and able to be accessed.
Posted 28 days ago. Nov 15, 2017 - 11:51 AEDT
Investigating
Customers are reporting difficulty accessing the Melbourne IT website, console and their own websites from non-mobile connections within Australia. International and mobile access appears unaffected.

We are investigating the issue as a priority with other ISPs to determine the source of the issue.
Posted 28 days ago. Nov 15, 2017 - 11:22 AEDT
This incident affected: Account Interfaces (Hosting console) and Network Infrastructure (External Network).