COVID-19 Update
Incident Report for Melbourne IT Service Status
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 14:05 AEST
Update
The global coronavirus epidemic, COVID-19, has impacted our support team staffing levels - our phone lines are temporarily closed. We have diverted our support team to address website and chat support enquiries. To submit an enquiry, click the Chat Now icon or submit a Support Enquiry on the Contact Us page. We are doing everything we can to return to normal services and appreciate your patience during these unprecedented times.
Posted Mar 17, 2020 - 12:54 AEDT
Monitoring
Coronavirus (COVID-19) has temporarily impacted our ability to respond to service calls before 8:30am and after 8:30pm AEST. If you have an urgent enquiry please click on Chat Now or if its outside of these hours send a Support Enquiry from the Contact Us page. We are doing everything we can to return to normal 24/7 service. Thank you for your patience.
Posted Mar 17, 2020 - 09:45 AEDT
This incident affected: Support Centre (Live Chat, Phone Sales/Support Line, Web/Email Support Enquires).