Error when attempting to access Microsoft 365 services
Incident Report for Melbourne IT Service Status
Resolved
Thank you for your patience while this was being resolved.

The issues affecting Microsoft 365 services have been resolved. Customers will be able to continue using Microsoft 365 services without any error messages.
Posted Jun 15, 2020 - 13:23 AEST
Identified
Microsoft 365 users may receive the following error message: "AADSTS90033: A transient error has occurred. Please try again." when attempting to access their Microsoft 365 services. Microsoft are currently investigating the issue and working to resolve this.
Posted Jun 15, 2020 - 10:07 AEST
This incident affected: Microsoft 365 Email & Apps (Email Services).