Phone System Degradation
Incident Report for Melbourne IT Service Status
Resolved
This incident has now been resolved and our phone systems are back online.
Posted Oct 25, 2018 - 19:25 AEDT
Investigating
The degradation with our phone systems has returned and we are currently working on restoring the system.
Posted Oct 25, 2018 - 15:58 AEDT
Monitoring
The degradation with our phone systems has now been resolved however we will continue to monitor this closely to prevent this from re-occurring.

We thank you for your patience during this period.
Posted Oct 25, 2018 - 13:08 AEDT
Investigating
We would like to advise customers that we are currently experiencing degradation with our phone system, which may result in poor call quality or disconnections. We recommend during this period that customers contact us via our Live chat and support email.

Updates will be provided as they are made available.
Posted Oct 25, 2018 - 12:39 AEDT
This incident affected: Support Centre (Phone Sales/Support Line).