Patching Update for Microsoft Exchange 2013 Platform
Incident Report for Melbourne IT Status Page
Resolved
This incident has been resolved.
Posted Mar 05, 2021 - 17:39 AEDT
Monitoring
We'd like to inform our Customers using the Microsoft Exchange 2013 services that we are performing maintenance updates to this platform.

Customers will still be able to use this service as normal (sending and receiving emails), however Customers may be prompted to log in to their accounts again.
Posted Mar 04, 2021 - 16:28 AEDT
This incident affected: Legacy Hosting (Managed Exchange Mail).