Cloud Email Issues
Incident Report for Melbourne IT Status Page
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 14:06 AEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 23, 2020 - 14:06 AEST
Identified
Customers using our Cloud Email and SpamExpert services have temporarily had their servers changed to continue receiving emails.

Our System Administrators will continue to monitor this to confirm that the Cloud Emails and Anti-spam services are operating effectively, while we work on permanently resolving these issues.
Posted May 22, 2020 - 12:07 AEST
This incident affected: Cloud Hosting (Email).