cPanel Email Delivery Issue
Incident Report for Melbourne IT Status Page
Resolved
We would like to advise our customer that all affected cPanel servers have now been removed from the blacklists and that this incident is now resolved.

We thank you for your patience during this period.
Posted 9 days ago. Nov 08, 2018 - 11:30 AEDT
Identified
We would like to advise that a number of cPanel servers have recently been listed on blacklists. Our technicians have raised requests to remove the affected servers.

We can confirm that a number of cPanel servers have since been removed and we are still working on removing the remaining servers.

As a temporary solution for customers that are using an email client (Outlook, Thunderbird, Mac Mail) can update their outgoing mail servers to their internet service provider's (ISP), to allow for emails to be sent out successfully.

Further updates will follow once more information is available.
Posted 16 days ago. Nov 01, 2018 - 13:38 AEDT
Investigating
We would like to advise that some customers that are hosted on our cPanel servers may experience email delivery issues to recipients. Our technicians are aware and are currently working on a solution as a priority.
Posted 24 days ago. Oct 24, 2018 - 16:15 AEDT
This incident affected: cPanel Hosting (Email).