Issue with the M365 Email Portal through The Console
Incident Report for Melbourne IT Status Page
Resolved
This incident has been resolved.
Posted Oct 07, 2020 - 12:53 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 06, 2020 - 20:20 AEDT
Identified
We would like to inform our customers of issues accessing the M365 Email Portal through the Console.

Customers wanting to access their M365 emails will still be able to, the Microsoft Email Portal can be accessed directly through the link: https://outlook.office.com/

Thank you for your patience while we work on this, we will provide updates as they become available
Posted Oct 06, 2020 - 12:34 AEDT
This incident affected: Professional Email (Office 365) and Account Interfaces (Hosting console).