Global Salesforce Outage - No impact to Core Services
Incident Report for Melbourne IT Status Page
Resolved
This incident has been resolved.
Posted May 12, 2021 - 14:25 AEST
Identified
Due to a Global Salesforce outage, our support form and LiveChat service is currently not operational. Please contact us via our Phone on 1300 654 677 for any urgent issues.
Posted May 12, 2021 - 09:58 AEST
This incident affected: Support Centre (Live Chat, Email Support, Domainz Support).