Phone/Live Chat Service Interruption
Incident Report for Melbourne IT Status Page
Resolved
The issue with our phone and live chat systems have been restored. We thank you for your patience during this period.
Posted 3 months ago. Jul 12, 2017 - 17:46 AEST
Investigating
We wish to advise our customers that we are currently experiencing technical difficulties with our phone and live chat systems. Our platform engineers are currently investigating this as a high priority.

We recommend customers requiring support use our email channels.

Thank you for your patience while we address this interruption.
Posted 3 months ago. Jul 12, 2017 - 17:20 AEST
This incident affected: Support Centre (Live Chat, 24h Phone Support).