Melbourne IT Phone Support Interruption
Incident Report for Melbourne IT Status Page
Resolved
Our phones lines have now been restored.
Posted 4 months ago. Jan 27, 2017 - 12:01 AEDT
Monitoring
We have resolved the issue causing inbound calls to fail, customers are now able to call our support and sales lines. We are still investigating a problem preventing us from making outbound calls. We will continue to update this alert until the issue is resolved.
Posted 4 months ago. Jan 25, 2017 - 23:38 AEDT
Investigating
We wish to advise our customers we are currently experiencing technical difficulties with our phone support system. Our platform engineers are currently investigating this as a high priority.

Customers requiring support can still use our live-chat and email services to contact us.

Thank you for your patience while we address this interruption.
Posted 4 months ago. Jan 25, 2017 - 15:40 AEDT
This incident affected: Support Centre (24h Phone Support, Domainz Support).