Cloud Mail Interface Disruption
Incident Report for Melbourne IT Status Page
Resolved
We now believe this issue to be resolved.
Posted 28 days ago. Nov 15, 2017 - 09:18 AEDT
Investigating
We are currently experiencing some Cloud Mail Interface issues. Users are currently not able to create new mailboxes or manage their current spam filter settings. The spam filter itself is functional.

Our server administrators are examining the issue, and we will provide more updates as soon as we have them.
Posted about 1 month ago. Nov 10, 2017 - 15:36 AEDT
This incident affected: Cloud Hosting (Email).