Phone System Degradation
Incident Report for Melbourne IT Status Page
Resolved
This incident has been resolved.
Posted 29 days ago. May 01, 2017 - 12:41 AEST
Update
We would like to advise customers that the issue we were experiencing regarding degradation with our phone system has returned and is being investigated with the highest priority. This may result in poor call quality or disconnections.
We recommend during this period that customers contact us via our Live chat and support email.
Posted about 1 month ago. Apr 28, 2017 - 12:10 AEST
Investigating
We would like to advise customers that we are currently experiencing degradation with our phone system, which may result in poor call quality or disconnections. We recommend during this period that customers contact us via our Live chat and support email.

Updates will be provided as they are made available.
Posted about 1 month ago. Apr 27, 2017 - 14:50 AEST
This incident affected: Support Centre (24h Phone Support).